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About this user manual

This user manual is included with delivery. 

Leuze lumiflex GmbH + Co. KG is not liable for damages caused by improper
use. Knowledge of this manual is an element of proper use. 

 Reprints and reproduction, including excerpts are permitted only with the express
permission of

Leuze lumiflex GmbH + Co. KG
Liebigstraße 4
D-82256 Fürstenfeldbruck
Tel. 0 81 41 / 53 50 - 0
Fax 0 81 41 / 53 50 - 1 90
E-Mail: lumiflex@leuze.de
http://www.leuze.de 

COMPACT.book  Seite 28  Dienstag, 6. Mai 2003  10:07 10



Diagnosis Software COMPACT 29

S
P

A
N

IS
C

H
IT

A
L

IE
N

IS
C

H
F

R
A

N
Z

Ö
S

IS
C

H
E

N
G

L
IS

H
D

E
U

T
S

C
H

Contents

1 COMPACT diagnosis Help Index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

2 What's new . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

3 Setup and Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

4 File menu commands . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

5 View menu commands . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

6 Help menu commands  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

7 Command File menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

7.1 Open log file (File menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
7.2 File Open dialog box  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33

8 Export log file command (File menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34

8.1 File Save As dialog box . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
8.2 1, 2, 3, 4 command (File menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
8.3 Exit command (File menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34

9 Command view menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35

9.1 Toolbar command (View menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
9.2 Toolbar  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
9.3 Status Bar command (View menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35
9.4 Status Bar  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

10 Command help menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

10.1 Index command (Help menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
10.2 Using Help command (Help menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
10.3 About command (Help menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
10.4 Context Help command . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
10.5 Title Bar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
10.6 Scroll bars  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37

11 Command system Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37

11.1 Size command (System menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
11.2 Move command (Control menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38
11.3 Minimize command (application Control menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38
11.4 Maximize command (System menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38
11.5 Close command (Control menus)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38
11.6 Restore command (Control menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
11.7 Switch to command (application Control menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39

12 Command View Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39

12.1 Graphic command (View menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39

13 Command Diagnosis Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40

13.1 Generate log file (receiver diagnosis menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40
13.2 Analyze log file command (receiver diagnosis menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . 40
13.3 Analyze log file dialog  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40
13.4 Logging options dialog . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41
13.5 Receiver data recording dialog  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42
13.6 Receiver menu commands (Diagnosis menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
13.7 Visualization (receiver diagnosis menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

COMPACT.book  Seite 29  Dienstag, 6. Mai 2003  10:07 10



30 Diagnosis Software COMPACT

D
E

U
T

S
C

H
E

N
G

L
IS

H
F

R
A

N
Z

Ö
S

IS
C

H
IT

A
L

IE
N

IS
C

H
S

P
A

N
IS

C
H

14 Diagnosis menu commands  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43

15 Command of Options menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44

15.1 Colors (Options menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
15.2 Test mode (Options menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
15.3 Port settings (Options menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
15.4 Color settings dialog  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
15.5 Test mode dialog . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45
15.6 Port settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45
15.7 Transmitter data recording dialog  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46
15.8 Generate log file (transmitter diagnosis menu)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47
15.9 Analyze log file dialog (transmitter diagnosis menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47
15.10 Analyze log file command (transmitter diagnosis menu) . . . . . . . . . . . . . . . . . . . . . . . . . 47
15.11 Transmitter menu commands (Diagnosis menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48
15.12 Report information dialog  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48

16 How to diagnose a COMPACT transmitter . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49

17 How to diagnose a COMPACT receiver  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50

18 How to visualize a COMPACT receiver . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51

18.1 Print command (File menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
18.2 Print dialog box  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
18.3 Print Setup command (File menu) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52
18.4 Print Setup dialog box . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52

COMPACT.book  Seite 30  Dienstag, 6. Mai 2003  10:07 10



Diagnosis Software COMPACT 31

S
P

A
N

IS
C

H
IT

A
L

IE
N

IS
C

H
F

R
A

N
Z

Ö
S

IS
C

H
E

N
G

L
IS

H
D

E
U

T
S

C
H

1 COMPACT diagnosis Help Index

Welcome to the COMPACT diagnosis software.

This program helps you to check your COMPACT transmitter and/or receiver.

Main topics:
What's new

Setup and Installation

How To ...
diagnose a COMPACT transmitter

diagnose a COMPACT receiver

visualize a COMPACT receiver

Commands
File menu

View menu

Diagnosis

Options

Help menu

2 What's new

This software helps you to check your COMPACT hardware.
You can do data recording on transmitter and receiver, analyze the recorded data and
do online visualization. Furthermore you can print a summary for recorded data and
even export this to a text file.

3 Setup and Installation

In order to use this Program you must the following hardware and software:

a IBM PC or 100% compatible with 4 MB RAM or more (8 MB for Windows 3.x and
16 MB for
Windows 95 recommended)

a Intel™ 486 processor with 33 MHz clock speed or higher (a Pentium™ with
75 MHz recommended)

a Hard disk with at least 5 MB free space

a free COM port with 16550 UART (FIFO)

Microsoft™ Windows™ 3.1 or higher

a VGA graphic card with at least 640*480 pixels resolution (800*600 recom-
mended)
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To install this software insert disk 1 in your floppy disk drive and

– with Windows™ 3.x or Windows NT™ 3.5x choose Run from the program
manager's file menu and enter 
A:\setup.exe (replace A:\ with the letter of your FDD)

– with Windows™ 95 or Windows NT™ 4.x press the Start button, choose Run and
enter A:\setup.exe (replace A:\ with the letter of your FDD)

The setup process is quite simple. You only have to enter the path where to install this
program.

After the setup program has finished, double click the Icon COMPACT from the
COMPACT program group.

To setup the hardware please follow the instructions delivered with your COMPACT
hardware.

The next step is to set the COM port in the Options menu.

That's it!

4 File menu commands

The File menu offers the following commands:

Open log file Opens an existing log file in text mode. Shortcut: Ctrl + O

Print log file Prints an log file. Shortcut: Ctrl + P

Print setup Selects a printer and printer connection.

Export log file Saves an opened log file in plain text. Shortcut: Ctrl + S

Exit Exits COMPACT diagnosis.
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5 View menu commands

The View menu offers the following commands:

6 Help menu commands

The Help menu offers the following commands, which provide you assistance with this
application: 

7 Command File menu 

7.1 Open log file (File menu)

Use this command to open an existing log file. The log file is parsed and a summary
information is generated.

You can create new documents with the show messages command.

Shortcuts

Toolbar: 
Keys: CTRL+O

7.2 File Open dialog box

The following options allow you to specify which file to open:

File Name
Type or select the filename you want to open. This box lists files with the extension you
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:

– Transmitter log files (*.lct)
– Receiver log files (*.lcr)

Drives
Select the drive in which COMPACT diagnosis stores the file that you want to open. 

Toolbar Shows or hides the toolbar.

Status Bar Shows or hides the status bar.

Graphic/Text Toggles between graphic and text mode.
Note that in graphic mode the menu item is Text and vice versa.

Index Offers you an index to topics on which you can get help.

Using Help Provides general instructions on using help.

About Displays the version number of this application.
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Directories
Select the directory in which COMPACT diagnosis stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 

8 Export log file command (File menu)

Use this command to export the active log file to plain text. When you save a log file,
COMPACT diagnosis displays the Report information dialog.

Shortcuts

Toolbar: 
Keys: CTRL+S

8.1 File Save As dialog box

The following options allow you to specify the name and location of the file you're about
to save:

File Name
Type a new filename to save a document with a different name. A filename can contain
up to eight characters and an extension of up to three characters. COMPACT
diagnosis adds the extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 

8.2 1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last
four documents you closed. Choose the number that corresponds with the document
you want to open.

8.3 Exit command (File menu)

Use this command to end your COMPACT diagnosis session.
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Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4

9 Command view menu

9.1 Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of
the most common commands in COMPACT diagnosis, such as File Open. A check
mark appears next to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.

9.2 Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.
The toolbar provides quick mouse access to many tools used in COMPACT diagnosis,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

9.3 Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be
executed by the selected menu item or depressed toolbar button, and keyboard latch
state. A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.

Click To 

Open an existing log file. COMPACT diagnosis displays the Open dialog box,
in which you can locate and open the desired file.

Save the active log file as text and prompts for a filename

Print the active log file.

Starts or stops the online visualization.
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9.4 Status Bar

The status bar is displayed at the bottom of the COMPACT diagnosis window. To
display or hide the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow
keys to navigate through menus. This area similarly shows messages that describe the
actions of toolbar buttons as you depress them, before releasing them. If after viewing
the description of the toolbar button command you wish not to execute the command,
then release the mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

10 Command help menu

10.1 Index command (Help menu)

Use this command to display the opening screen of Help. From the opening screen,
you can jump to step-by-step instructions for using COMPACT diagnosis and various
types of reference information. 

Once you open Help, you can click the Contents button whenever you want to return
to the opening screen.

10.2 Using Help command (Help menu)

Use this command for instructions about using Help.

10.3 About command (Help menu)

Use this command to display the copyright notice and version number of your copy of
COMPACT diagnosis.

10.4 Context Help command 

Use the Context Help command to obtain help on some portion of COMPACT
diagnosis. When you choose the Toolbar's Context Help button, the mouse pointer will
change to an arrow and question mark. Then click somewhere in the COMPACT
diagnosis window, such as another Toolbar button. The Help topic will be shown for the
item you clicked.

Indicator Description

CAP The Caps Lock key is latched down.

NUM The Num Lock key is latched down.

SCRL The Scroll Lock key is latched down.
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Shortcut
Keys: SHIFT+F1

10.5 Title Bar

The title bar is located along the top of a window. It contains the name of the
application and log file or the current mode.

To move the window, drag the title bar. Note: You can also move dialog boxes by
dragging their title bars.

A title bar may contain the following elements:

Application Control-menu button

Document Control-menu button

Maximize button

Minimize button

Name of the application

Name of the document

Restore button

10.6 Scroll bars

Displayed at the right and bottom edges of the document window in text mode. The
scroll boxes inside the scroll bars indicate your vertical and horizontal location in the
document. You can use the mouse to scroll to other parts of the document.

11 Command system Menu

11.1 Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window
with the arrow keys.

After the pointer changes to the four-headed arrow:

1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the
pointer to the border you
want to move. 

2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note: This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.
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11.2 Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window
or dialog box with the arrow keys.

Note: This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7

11.3 Minimize command (application Control menu)

Use this command to reduce the COMPACT diagnosis> window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9

11.4 Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the
title bar.

Keys: CTRL+F10 enlarges a document window.

11.5 Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Shortcuts
Keys: ALT+F4 closes the COMPACT window or dialog box
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11.6 Restore command (Control menu)

Use this command to return the active window to its size and position before you chose
the Maximize or Minimize command.

11.7 Switch to command (application Control menu)

Use this command to display a list of all open applications. Use this "Task List" to
switch to or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box
with the following options:

Task List
Select the application you want to switch to or close.

Switch To
Makes the selected application active.

End Task
Closes the selected application.

Cancel
Closes the Task List box.

Cascade
Arranges open applications so they overlap and you can see each title bar. This option
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap. This option does not
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.

12 Command View Menu

12.1 Graphic command (View menu)

This command toggles between graphic and text mode.

In graphic mode you can visualize data received by the receiver, record transmitter or
receiver data to a log file and analyze a log file.

The text mode gives summary information about a log file. You can print or export this
summary as text file.
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13 Command Diagnosis Menu

13.1 Generate log file (receiver diagnosis menu)

This command shows the receiver data recording dialog.

Shortcuts
Keys: F5

13.2 Analyze log file command (receiver diagnosis menu)

This command shows the analyze log file dialog. Choose this command to analyze a
transmitter log file.

Shortcuts
Keys: SHIFT+F5

13.3 Analyze log file dialog

With this dialog you can analyze a log file recorded with the receiver data recording
dialog.

If the default log file receiver.lcr exists it is initially displayed. To choose a different log
file click the button Browse.

Use the scroll bar to position the error you are interested in.
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13.4 Logging options dialog

With this dialog you can log only selected errors and/or states.

To log all errors and/or states choose the Log all radio button, to specify what to log
choose Log specified.

To log interrupted beams check Interrupted beams.

To log weak beams check Weak beams.

If you are interested in state changes choose either Change state to log every state
change or Errors only to specify which errors you are interested in. To select the
errors to log select the errors in the errors list box.
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13.5 Receiver data recording dialog

With this dialog you can do the data recording. In the Data group box you can see the
data as it is received from the transmitter.

To start data recording click the button Start diagnosis.

To write a log file check the check box write log file. If this check box is checked the
button Browse is enabled and you can choose a filename and path. The default
filename is receiver.lcr.

To record only selected errors choose the button Options to show the Logging options
dialog.

Hint:
waiting for copyright message... means that you have to start data recording with
switched off light curtain (no data transmission). After you have pressed Start
Diagnosis start your light curtain. The first sent data is the copyright and the firmware
version of your light curtain. If this data wasn’t received (diagnosis is started and light
curtain is already switched on), the message waiting for copyright message...
remains on the dialog.
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13.6 Receiver menu commands (Diagnosis menu)

The Receiver menu offers the following commands:

This command is enabled only in graphic mode. To enable graphic mode choose
Graphic from the View menu. If this menu item is checked then the graphic mode is
enabled.

13.7 Visualization (receiver diagnosis menu)

This command starts or stops the on-line visualization of the COMPACT receiver.

You can see the beams as graphic lines.

Shortcuts

Toolbar:
Keys: F8

14 Diagnosis menu commands

The Diagnosis menu offers the following commands:

The commands of this menu and its submenus are enabled only if in graphic mode. To
enable graphic mode choose Graphic from the View menu. If this menu item is
checked then the graphic mode is enabled.

generate log file Shows dialog for data recording. Shortcut: F5

analyze log file Shows dialog for analyzing a recorded log file. Shortcut: SHIFT+F5

Visualization Starts or stops the on-line diagnosis of receiver data. Shortcut: F8

Transmitter Shows commands for transmitter diagnosis

Receiver Shows commands for receiver diagnosis
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15 Command of Options menu

Options
The File menu offers the following commands:

The commands of this menu and its submenus are enabled only if in graphic mode. To
enable graphic mode choose Graphic from the View menu. If this menu item is
checked then the graphic mode is enabled.

15.1 Colors (Options menu)

This command shows the Colors dialog. With this dialog you can modify the colors of
the on-line visualisation.

15.2 Test mode (Options menu)

This command shows the Testmode dialog. With this dialog you can activate a test
mode. In test mode the COMPACT software reads test data from a file and not from the
Hardware. This allows you to explore the COMPACT diagnosis software.

15.3 Port settings (Options menu)

This command shows the Port settings dialog. With this dialog you can set the serial
port that COMPACT diagnosis is using.

15.4 Color settings dialog

With this dialog you can set the colors for the Frame which represents the COMPACT
hardware, the Beams when visible, invisible and weak.

For weak beams you can also check the check box to show these beams with a dotted
line. When you choose the buttons the Color dialog is displayed.

Colors Displays a dialog where you can set the colors of the on-line
visualization

Test mode Displays a dialog where you can enable a test mode for this
application

Port settings Displays a dialog where you can set the port settings that
COMPACT will use for data connection
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15.5 Test mode dialog

With this dialog you can choose datafiles to test the application and to learn how this
software is used. To enable test mode check the enable test check box.

When enabled, the data is read from the files shown in this dialog and not from the
communication port.

15.6 Port settings

With this dialog you can set the various options for the communication port. In general
you must only change the port where your COMPACT hardware is connected.
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15.7 Transmitter data recording dialog

With this dialog you can do the data recording. In the Data group box you can see the
data as it is received from the transmitter.

To start data recording click the button Start diagnosis.

To write a log file check the check box write log file. If this check box is checked the
button Browse is enabled and you can choose a filename and path. The default
filename is Sender.lct.

Hint:
waiting for copyright message... means that you have to start data recording with
switched off light curtain (no data transmission). After you have pressed Start
Diagnosis start your light curtain. The first sent data is the copyright and the firmware
version of your light curtain. If this data wasn’t received (diagnosis is started and light
curtain is already switched on), the message waiting for copyright message...
remains on the dialog.

Port: Choose the right port from the list

Baud rate: The transmitter operates at 9600 baud, the receiver at
57600 baud.

Parity: Choose none (the default)

Stop bits: Choose 1 (the default)
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15.8 Generate log file (transmitter diagnosis menu)

This command shows the transmitter data recording dialog.

Shortcuts
Keys: F4

15.9 Analyze log file dialog (transmitter diagnosis menu)

With this dialog you can analyze a log file recorded with the transmitter data recording
dialog.

If the default log file sender.lct exists it is initially displayed. To choose a different log
file click the button Browse.

Use the scroll bar to position the error you are interested in.

15.10 Analyze log file command (transmitter diagnosis menu)

This command shows the analyze log file dialog. Choose this command to analyze a
transmitter log file.

Shortcuts
Keys: Shift+F4
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15.11 Transmitter menu commands (Diagnosis menu)

The Transmitter menu offers the following commands:

This command is enabled only if in graphic mode. To enable graphic mode choose
Graphic from the View menu. 
If this menu item is checked then the graphic mode is enabled.

15.12 Report information dialog

This dialog is displayed before exporting or printing a log file. You can enter information
which is included in the resulting output. Furthermore you can choose what further
information should be included by checking the appropriate check boxes.

generate log file Shows dialog for data recording. Shortcut: F4

analyze log file Shows dialog for analyzing a recorded log file. Shortcut: Shift+F4

Serial number: Enter the serial number of the device you are testing. (required)

User name: Enter your name. (required)

Type: Enter the type of the device you are testing. (optional)

Comment: Enter up to 100 characters of further information that should be
included in the output. (optional)
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16 How to diagnose a COMPACT transmitter

Follow these simple steps to test a COMPACT transmitter.

Print legend If checked a description of the columns in the output is included.
(enabled only if current file is a receiver log file)

Print summary If checked the summary information is included in the output as
shown in this dialog.
If the current file is a transmitter log file then Double Scan is not
included.

Print detailed text If checked detailed error information is included in the output.

Browse Displays the Save As dialog box where you can choose a file name
and path for export. (enabled only if exporting a file)

1 Make sure the COMPACT transmitter is connected to a COM port of your
computer and that COMPACT diagnosis software is setup correctly

2 Make sure that COMPACT diagonsis software is in graphic mode. The title
bar should read like COMPACT Diagnosis - (Graphic mode). You toggle
between text and graphic mode by choosing View ⇒ graphik or View ⇒
Text. 

3 Show the transmitter data recording dialog by choosing Diagnosis ⇒
Transmitter ⇒ generate log file from the menu bar or via F4

4 Make sure the write log file checkbox is checked. You can choose a file
name and path by clicking the Browse command button or accept the default
(sender.lct).

5 Click the Start diagnosis command button

6 Switch on power at the COMPACT transmitter

7 After a few seconds you should see the copyright message and blocks
received increasing

8 The configuration of your COMPACT transmitter should match the data
displayed in the Data group

9 Click Stop diagnosis command button

10 Close the dialog by choosing Cancel or by pressing ESC

11 Show the analyze log file dialog by choosing Diagnosis ⇒ Transmitter ⇒
analyze log file from the menu bar or via SHIFT+F4

12 If you have used the default file name for data recording you already see the
log file displayed. Otherwise select the log file by clicking Browse

13 Step through the log file with the scrollbar

14 Close the dialog by choosing Cancel or by pressing ESC

15 Enter Text mode by selecting View ⇒ text

16 Open the log file by choosing File ⇒ Open log file
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Congratulations! You have successfully tested your COMPACT transmitter.

17 How to diagnose a COMPACT receiver

Follow these simple steps to test a COMPACT receiver.

Congratulations! You have successfully tested your COMPACT receiver.

17 Choose File ⇒ Print log file to show the report information dialog

18 Enter the information required and click Print

1 Make sure the COMPACT receiver is connected to a COM port of your
computer and that COMPACT diagnosis software is setup correctly

2 Make sure that COMPACT diagonsis software is in graphic mode. The title
bar should read like COMPACT Diagnosis - (Graphic mode). You toggle
between text and graphic mode by choosing View ⇒ graphik or View ⇒
Text.

3 Show the receiver data recording dialog by choosing Diagnosis ⇒ Re-
ceiver ⇒ generate log file from the menu bar or via F5

4 Make sure the write log file checkbox is checked. You can choose a file
name and path by clicking the Browse command button or accept the default
(receiver.lcr).

5 You can select logging options by clicking the Options command button if
you like

6 Click the Start diagnosis command button

7 Switch on power at the COMPACT receiver

8 After a few seconds you should see the copyright message and blocks
received increasing

9 The configuration of your COMPACT receiver should match the data
displayed in the Data group

10 Click Stop diagnosis command button

11 Close the dialog by choosing Cancel or by pressing ESC

12 Show the analyze log file dialog by choosing Diagnosis ⇒ Receiver ⇒
analyze log file from the menu bar or via SHIFT+F5

13 If you have used the default file name for data recording you already see the
log file displayed.
Otherwise select the log file by clicking Browse

14 Step through the log file with the scrollbar

15 Close the dialog by choosing Cancel or by pressing ESC

16 Enter Text mode by selecting View ⇒ text

17 Open the log file by choosing File ⇒ Open log file

18 Choose File ⇒ Print log file to show the report information dialog

19 Enter the information required and click Print
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18 How to visualize a COMPACT receiver

Follow these simple steps to visualize COMPACT receiver data on-line.

Congratulations! You have successfully tested your COMPACT receiver.

1 Make sure the COMPACT receiver is connected to a COM port of your
computer and that COMPACT diagnosis software is setup correctly

2 Make sure that COMPACT diagnosis software is in graphic mode. The title
bar should read like COMPACT Diagnosis - (Graphic mode). You toggle
between text and graphic mode by choosing View ⇒ graphik or View ⇒
Text.

3 Start the on-line visualization by choosing Diagnosis ⇒ Receiver ⇒
Visualization file from the menu bar or via F8

4 Switch on power at the COMPACT receiver

5 After a few seconds you should see the beams displayed

6 The number of beams displayed should match the number of beams of your
COMPACT receiver

7 Stop the on-line visualization by choosing Diagnosis ⇒ Receiver ⇒
Visualization file from the menu bar or via F8Close the dialog by choosing
Cancel or by pressing ESC

8 Move the mouse over the beams. At the statusbar you can see the beam
count and the currently selected (by mouse pointer) beam number.
Hint: This kind of visualization is not available in zoom mode.

COMPACT.book  Seite 51  Dienstag, 6. Mai 2003  10:07 10



52 Diagnosis Software COMPACT

D
E

U
T

S
C

H
E

N
G

L
IS

H
F

R
A

N
Z

Ö
S

IS
C

H
IT

A
L

IE
N

IS
C

H
S

P
A

N
IS

C
H

18.1 Print command (File menu)

Use this command to print a document. This command presents the Report information
dialog, where you may specify the output.

Shortcuts

Toolbar: 
Keys: CTRL+P

18.2 Print dialog box

The following options allow you to specify how the document should be printed:

Printer
This is the active printer and printer connection. Choose the Setup option to change the
printer and printer 
connection.

Setup
Displays a Print Setup dialog box, so you can select a printer and printer connection.

18.3 Print Setup command (File menu)

Use this command to select a printer and a printer connection. This command presents
a Print Setup dialog box, where you specify the printer and its connection.

18.4 Print Setup dialog box

The following options allow you to select the destination printer and its connection.

Printer
Select the printer you want to use. Choose the Default Printer; or choose the Specific
Printer option and select 
one of the current installed printers shown in the box. You install printers and configure
ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources. Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.
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